CVE-2024-5261

Name
CVE-2024-5261
Description
Improper Certificate Validation vulnerability in LibreOffice "LibreOfficeKit" mode disables TLS certification verification LibreOfficeKit can be used for accessing LibreOffice functionality through C/C++. Typically this is used by third party components to reuse LibreOffice as a library to convert, view or otherwise interact with documents. LibreOffice internally makes use of "curl" to fetch remote resources such as images hosted on webservers. In affected versions of LibreOffice, when used in LibreOfficeKit mode only, then curl's TLS certification verification was disabled (CURLOPT_SSL_VERIFYPEER of false) In the fixed versions curl operates in LibreOfficeKit mode the same as in standard mode with CURLOPT_SSL_VERIFYPEER of true. This issue affects LibreOffice before version 24.2.4.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
https://www.libreoffice.org/about-us/security/advisories/cve-2024-5261

Match rules

CPE URI Source package Min version Max version
libreoffice >= 24.2 < 24.2.4
cpe:2.3:a:libreoffice:libreoffice:24.2.4:*:*:*:*:*:*:* libreoffice >= 0 < 24.2.4

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
libreoffice edge-community 7.6.7.2-r0 Timo Teräs <timo.teras@iki.fi> possibly vulnerable
libreoffice 3.20-community 7.6.7.2-r0 Timo Teräs <timo.teras@iki.fi> possibly vulnerable