CVE-2024-29510

Name
CVE-2024-29510
Description
Artifex Ghostscript before 10.03.1 allows memory corruption, and SAFER sandbox bypass, via format string injection with a uniprint device.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
https://bugs.ghostscript.com/show_bug.cgi?id=707662
https://www.openwall.com/lists/oss-security/2024/07/03/7
https://codeanlabs.com/blog/research/cve-2024-29510-ghostscript-format-string-exploitation/

Match rules

CPE URI Source package Min version Max version
n/a == n/a == n/a
cpe:2.3:a:ghostscript:ghostscript:0:*:*:*:*:*:*:* ghostscript >= 0 < 10.03.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
ghostscript edge-main 10.03.1-r0 Cameron Banta <cbanta@gmail.com> fixed
ghostscript 3.18-main 10.02.0-r0 Cameron Banta <cbanta@gmail.com> possibly vulnerable
ghostscript 3.17-main 10.01.2-r0 Cameron Banta <cbanta@gmail.com> possibly vulnerable
ghostscript 3.20-main 10.03.1-r0 Cameron Banta <cbanta@gmail.com> fixed
ghostscript 3.19-main 10.03.1-r0 Cameron Banta <cbanta@gmail.com> fixed