CVE-2024-28835

Name
CVE-2024-28835
Description
A flaw has been discovered in GnuTLS where an application crash can be induced when attempting to verify a specially crafted .pem bundle using the "certtool --verify-chain" command.
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
secalert@redhat.com https://access.redhat.com/security/cve/CVE-2024-28835
secalert@redhat.com https://bugzilla.redhat.com/show_bug.cgi?id=2269084
secalert@redhat.com https://lists.gnupg.org/pipermail/gnutls-help/2024-March/004845.html
secalert@redhat.com https://access.redhat.com/errata/RHSA-2024:1879
secalert@redhat.com https://access.redhat.com/errata/RHSA-2024:2570
secalert@redhat.com http://www.openwall.com/lists/oss-security/2024/03/22/1
secalert@redhat.com http://www.openwall.com/lists/oss-security/2024/03/22/2
secalert@redhat.com https://access.redhat.com/errata/RHSA-2024:2889

Match rules

CPE URI Source package Min version Max version

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
gnutls 3.19-main 3.8.4-r0 Natanael Copa <ncopa@alpinelinux.org> fixed
gnutls 3.18-main 3.8.4-r0 Natanael Copa <ncopa@alpinelinux.org> fixed
gnutls edge-main 3.8.5-r0 Natanael Copa <ncopa@alpinelinux.org> fixed
gnutls 3.20-main 3.8.5-r0 Natanael Copa <ncopa@alpinelinux.org> fixed