CVE-2024-27281

Name
CVE-2024-27281
Description
An issue was discovered in RDoc 6.3.3 through 6.6.2, as distributed in Ruby 3.x through 3.3.0. When parsing .rdoc_options (used for configuration in RDoc) as a YAML file, object injection and resultant remote code execution are possible because there are no restrictions on the classes that can be restored. (When loading the documentation cache, object injection and resultant remote code execution are also possible if there were a crafted cache.) The main fixed version is 6.6.3.1. For Ruby 3.0 users, a fixed version is rdoc 6.3.4.1. For Ruby 3.1 users, a fixed version is rdoc 6.4.1.1. For Ruby 3.2 users, a fixed version is rdoc 6.5.1.1.
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
cve@mitre.org https://hackerone.com/reports/1187477
cve@mitre.org https://www.ruby-lang.org/en/news/2024/03/21/rce-rdoc-cve-2024-27281/

Match rules

CPE URI Source package Min version Max version

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
ruby 3.19-main 3.2.4-r0 Jakub Jirutka <jakub@jirutka.cz> fixed
ruby 3.18-main 3.2.4-r0 Jakub Jirutka <jakub@jirutka.cz> fixed
ruby 3.17-main 3.1.5-r0 Jakub Jirutka <jakub@jirutka.cz> fixed
ruby 3.16-main 3.1.5-r0 Jakub Jirutka <jakub@jirutka.cz> fixed
ruby edge-main 3.3.1-r0 Jakub Jirutka <jakub@jirutka.cz> fixed
ruby 3.20-main 3.3.1-r0 Jakub Jirutka <jakub@jirutka.cz> fixed