CVE-2024-25004

Name
CVE-2024-25004
Description
KiTTY versions 0.76.1.13 and before is vulnerable to a stack-based buffer overflow via the username, occurs due to insufficient bounds checking and input sanitization (at line 2600). This allows an attacker to overwrite adjacent memory, which leads to arbitrary code execution.
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
cve@mitre.org http://packetstormsecurity.com/files/177032/KiTTY-0.76.1.13-Buffer-Overflows.html
cve@mitre.org https://blog.defcesco.io/CVE-2024-25003-CVE-2024-25004
Exploit http://seclists.org/fulldisclosure/2024/Feb/13
Exploit http://seclists.org/fulldisclosure/2024/Feb/14
cve@mitre.org http://packetstormsecurity.com/files/177031/KiTTY-0.76.1.13-Command-Injection.html

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:9bis:kitty:*:*:*:*:*:windows:*:* kitty >= None <= 0.76.1.13

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
kitty 3.19-community 0.31.0-r4 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
kitty edge-community 0.31.0-r7 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
kitty 3.20-community 0.31.0-r7 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable