CVE-2024-24819

Name
CVE-2024-24819
Description
icingaweb2-module-incubator is a working project of bleeding edge Icinga Web 2 libraries. In affected versions the class `gipfl\Web\Form` is the base for various concrete form implementations [1] and provides protection against cross site request forgery (CSRF) by default. This is done by automatically adding an element with a CSRF token to any form, unless explicitly disabled, but even if enabled, the CSRF token (sent during a client's submission of a form relying on it) is not validated. This enables attackers to perform changes on behalf of a user which, unknowingly, interacts with a prepared link or website. The version 0.22.0 is available to remedy this issue. Users are advised to upgrade. There are no known workarounds for this vulnerability.
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
security-advisories@github.com https://github.com/Icinga/icingaweb2-module-incubator/commit/db7dc49585fee0b4e96be666d7f6009a74a1ccb5
security-advisories@github.com https://github.com/Icinga/icingaweb2-module-incubator/security/advisories/GHSA-p8vv-9pqq-rm8p
security-advisories@github.com https://github.com/search?q=gipfl%5CWeb%5CForm%3B&type=code

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:icinga:icingaweb2-module-incubator:*:*:*:*:*:*:*:* icingaweb2-module-incubator >= None < 0.22.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
icingaweb2-module-incubator edge-community 0.20.0-r1 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
icingaweb2-module-incubator 3.19-community 0.20.0-r1 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
icingaweb2-module-incubator 3.20-community 0.20.0-r1 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable