CVE-2024-24806

Name
CVE-2024-24806
Description
libuv is a multi-platform support library with a focus on asynchronous I/O. The `uv_getaddrinfo` function in `src/unix/getaddrinfo.c` (and its windows counterpart `src/win/getaddrinfo.c`), truncates hostnames to 256 characters before calling `getaddrinfo`. This behavior can be exploited to create addresses like `0x00007f000001`, which are considered valid by `getaddrinfo` and could allow an attacker to craft payloads that resolve to unintended IP addresses, bypassing developer checks. The vulnerability arises due to how the `hostname_ascii` variable (with a length of 256 bytes) is handled in `uv_getaddrinfo` and subsequently in `uv__idna_toascii`. When the hostname exceeds 256 characters, it gets truncated without a terminating null byte. As a result attackers may be able to access internal APIs or for websites (similar to MySpace) that allows users to have `username.example.com` pages. Internal services that crawl or cache these user pages can be exposed to SSRF attacks if a malicious user chooses a long vulnerable username. This issue has been addressed in release version 1.48.0. Users are advised to upgrade. There are no known workarounds for this vulnerability.
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
security-advisories@github.com https://github.com/libuv/libuv/commit/0f2d7e784a256b54b2385043438848047bc2a629
security-advisories@github.com https://github.com/libuv/libuv/commit/3530bcc30350d4a6ccf35d2f7b33e23292b9de70
security-advisories@github.com https://github.com/libuv/libuv/commit/c858a147643de38a09dd4164758ae5b685f2b488
security-advisories@github.com https://github.com/libuv/libuv/commit/e0327e1d508b8207c9150b6e582f0adf26213c39
security-advisories@github.com https://github.com/libuv/libuv/security/advisories/GHSA-f74f-cvh7-c6q6
security-advisories@github.com http://www.openwall.com/lists/oss-security/2024/02/08/2
security-advisories@github.com http://www.openwall.com/lists/oss-security/2024/02/11/1
security-advisories@github.com https://lists.debian.org/debian-lts-announce/2024/03/msg00005.html
security-advisories@github.com http://www.openwall.com/lists/oss-security/2024/03/11/1

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:libuv:libuv:*:*:*:*:*:*:*:* libuv >= 1.24.0 <= 1.48.0
cpe:2.3:a:libuv:libuv:*:*:*:*:*:*:*:* libuv >= 1.45.0 < 1.48.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
libuv edge-main 1.48.0-r0 Natanael Copa <ncopa@alpinelinux.org> fixed
libuv 3.19-main 1.47.0-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
libuv 3.18-main 1.44.2-r2 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
libuv 3.17-main 1.44.2-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
libuv 3.16-main 1.44.1-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
libuv 3.20-main 1.48.0-r0 Natanael Copa <ncopa@alpinelinux.org> fixed