CVE-2024-23898

Name
CVE-2024-23898
Description
Jenkins 2.217 through 2.441 (both inclusive), LTS 2.222.1 through 2.426.2 (both inclusive) does not perform origin validation of requests made through the CLI WebSocket endpoint, resulting in a cross-site WebSocket hijacking (CSWSH) vulnerability, allowing attackers to execute CLI commands on the Jenkins controller.
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
jenkinsci-cert@googlegroups.com http://www.openwall.com/lists/oss-security/2024/01/24/6
jenkinsci-cert@googlegroups.com https://www.jenkins.io/security/advisory/2024-01-24/#SECURITY-3315

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:jenkins:*:*:*:*:-:*:*:* jenkins >= 2.217 <= 2.441
cpe:2.3:a:jenkins:jenkins:*:*:*:*:lts:*:*:* jenkins >= 2.222.1 <= 2.426.2

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins edge-community 2.426.3-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.19-community 2.414.3-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable