CVE-2024-23771

Name
CVE-2024-23771
Description
darkhttpd before 1.15 uses strcmp (which is not constant time) to verify authentication, which makes it easier for remote attackers to bypass authentication via a timing side channel.
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
cve@mitre.org https://github.com/emikulic/darkhttpd/commit/f477619d49f3c4de9ad59bd194265a48ddc03f04
cve@mitre.org https://github.com/emikulic/darkhttpd/compare/v1.14...v1.15
cve@mitre.org http://www.openwall.com/lists/oss-security/2024/01/25/1

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:unix4lyfe:darkhttpd:*:*:*:*:*:*:*:* darkhttpd >= None < 1.15

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
darkhttpd edge-main 1.15-r0 Alan Lacerda <alacerda@alpinelinux.org> fixed
darkhttpd 3.19-main 1.14-r1 Alan Lacerda <alacerda@alpinelinux.org> possibly vulnerable
darkhttpd 3.18-main 1.14-r1 Alan Lacerda <alacerda@alpinelinux.org> possibly vulnerable
darkhttpd 3.17-main 1.14-r0 Alan Lacerda <alacerda@alpinelinux.org> possibly vulnerable
darkhttpd 3.16-main 1.14-r0 Alan Lacerda <alacerda@alpinelinux.org> possibly vulnerable