CVE-2024-23749

Name
CVE-2024-23749
Description
KiTTY versions 0.76.1.13 and before is vulnerable to command injection via the filename variable, occurs due to insufficient input sanitization and validation, failure to escape special characters, and insecure system calls (at lines 2369-2390). This allows an attacker to add inputs inside the filename variable, leading to arbitrary code execution.
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
cve@mitre.org http://packetstormsecurity.com/files/177031/KiTTY-0.76.1.13-Command-Injection.html
cve@mitre.org https://blog.defcesco.io/CVE-2024-23749
Exploit http://seclists.org/fulldisclosure/2024/Feb/13
Exploit http://seclists.org/fulldisclosure/2024/Feb/14

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:9bis:kitty:*:*:*:*:*:windows:*:* kitty >= None <= 0.76.1.13

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
kitty 3.19-community 0.31.0-r3 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
kitty edge-community 0.31.0-r4 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable