Squid is a caching proxy for the Web. Due to an expired pointer reference bug, Squid prior to version 6.6 is vulnerable to a Denial of Service attack against Cache Manager error responses. This problem allows a trusted client to perform Denial of Service when generating error pages for Client Manager reports. Squid older than 5.0.5 have not been tested and should be assumed to be vulnerable. All Squid-5.x up to and including 5.9 are vulnerable. All Squid-6.x up to and including 6.5 are vulnerable. This bug is fixed by Squid version 6.6. In addition, patches addressing this problem for the stable releases can be found in Squid's patch archives. As a workaround, prevent access to Cache Manager using Squid's main access control: `http_access deny manager`.
NVD Severity
Other trackers
Mailing lists
GitHub (code, issues), Aports (code, issues)


Type URI

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:squid-cache:squid:*:*:*:*:*:*:*:* squid >= 5.0 <= 5.9
cpe:2.3:a:squid-cache:squid:*:*:*:*:*:*:*:* squid >= 6.0 < 6.6

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
squid 3.18-main 5.9-r0 Natanael Copa <> possibly vulnerable
squid 3.17-main 5.7-r0 Natanael Copa <> possibly vulnerable
squid 3.16-main 5.5-r1 Natanael Copa <> possibly vulnerable