Versions of the package dash-core-components before 2.13.0; all versions of the package dash-core-components; versions of the package dash before 2.15.0; all versions of the package dash-html-components; versions of the package dash-html-components before 2.0.16 are vulnerable to Cross-site Scripting (XSS) when the href of the a tag is controlled by an adversary. An authenticated attacker who stores a view that exploits this vulnerability could steal the data that's visible to another user who opens that view - not just the data already included on the page, but they could also, in theory, make additional requests and access other data accessible to this user. In some cases, they could also steal the access tokens of that user, which would allow the attacker to act as that user, including viewing other apps and resources hosted on the same server. **Note:** This is only exploitable in Dash apps that include some mechanism to store user input to be reloaded by a different user.
NVD Severity
Other trackers
Mailing lists
GitHub (code, issues), Aports (code, issues)


Type URI

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:plotly:dash:*:*:*:*:*:*:*:* dash >= None < 2.13.0
cpe:2.3:a:plotly:dash:*:*:*:*:*:*:*:* dash >= 2.14.0 < 2.15.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
dash edge-main 0.5.12-r2 Natanael Copa <> possibly vulnerable
dash 3.19-main 0.5.12-r2 Natanael Copa <> possibly vulnerable
dash 3.18-main 0.5.12-r2 Natanael Copa <> possibly vulnerable
dash 3.17-main Natanael Copa <> possibly vulnerable