CVE-2024-0727

Name
CVE-2024-0727
Description
Issue summary: Processing a maliciously formatted PKCS12 file may lead OpenSSL to crash leading to a potential Denial of Service attack Impact summary: Applications loading files in the PKCS12 format from untrusted sources might terminate abruptly. A file in PKCS12 format can contain certificates and keys and may come from an untrusted source. The PKCS12 specification allows certain fields to be NULL, but OpenSSL does not correctly check for this case. This can lead to a NULL pointer dereference that results in OpenSSL crashing. If an application processes PKCS12 files from an untrusted source using the OpenSSL APIs then that application will be vulnerable to this issue. OpenSSL APIs that are vulnerable to this are: PKCS12_parse(), PKCS12_unpack_p7data(), PKCS12_unpack_p7encdata(), PKCS12_unpack_authsafes() and PKCS12_newpass(). We have also fixed a similar issue in SMIME_write_PKCS7(). However since this function is related to writing data we do not consider it security significant. The FIPS modules in 3.2, 3.1 and 3.0 are not affected by this issue.
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
openssl-security@openssl.org https://github.com/openssl/openssl/commit/09df4395b5071217b76dc7d3d2e630eb8c5a79c2
openssl-security@openssl.org https://github.com/openssl/openssl/commit/775acfdbd0c6af9ac855f34969cdab0c0c90844a
openssl-security@openssl.org https://github.com/openssl/openssl/commit/d135eeab8a5dbf72b3da5240bab9ddb7678dbd2c
openssl-security@openssl.org https://github.openssl.org/openssl/extended-releases/commit/03b3941d60c4bce58fab69a0c22377ab439bc0e8
openssl-security@openssl.org https://github.openssl.org/openssl/extended-releases/commit/aebaa5883e31122b404e450732dc833dc9dee539
openssl-security@openssl.org https://www.openssl.org/news/secadv/20240125.txt
openssl-security@openssl.org https://security.netapp.com/advisory/ntap-20240208-0006/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:openssl:openssl:*:*:*:*:*:*:*:* openssl >= 1.0.2 < 1.0.2zj
cpe:2.3:a:openssl:openssl:*:*:*:*:*:*:*:* openssl >= 1.1.1 < 1.1.1x
cpe:2.3:a:openssl:openssl:*:*:*:*:*:*:*:* openssl >= 3.0.0 < 3.0.13
cpe:2.3:a:openssl:openssl:*:*:*:*:*:*:*:* openssl >= 3.1.0 < 3.1.5
cpe:2.3:a:openssl:openssl:3.2.0:-:*:*:*:*:*:* openssl == None == 3.2.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
openssl 3.19-main 3.1.4-r5 Ariadne Conill <ariadne@dereferenced.org> fixed
openssl 3.18-main 3.1.4-r5 Ariadne Conill <ariadne@dereferenced.org> fixed
openssl 3.17-main 3.0.12-r4 Ariadne Conill <ariadne@dereferenced.org> fixed
openssl 3.16-main 1.1.1w-r1 Timo Teras <timo.teras@iki.fi> possibly vulnerable