CVE-2023-6992

Name
CVE-2023-6992
Description
Cloudflare version of zlib library was found to be vulnerable to memory corruption issues affecting the deflation algorithm implementation (deflate.c). The issues resulted from improper input validation and heap-based buffer overflow. A local attacker could exploit the problem during compression using a crafted malicious file potentially leading to denial of service of the software. Patches: The issue has been patched in commit 8352d10 https://github.com/cloudflare/zlib/commit/8352d108c05db1bdc5ac3bdf834dad641694c13c . The upstream repository is not affected.
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
cna@cloudflare.com https://github.com/cloudflare/zlib
cna@cloudflare.com https://github.com/cloudflare/zlib/security/advisories/GHSA-vww9-j87r-4cqh

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:cloudflare:zlib:*:*:*:*:*:*:*:* zlib >= None < 2023-11-16

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
zlib 3.18-main 1.2.13-r1 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
zlib 3.17-main 1.2.13-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
zlib 3.16-main 1.2.12-r3 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
zlib 3.19-main 1.3.1-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
zlib edge-main 1.3.1-r1 Natanael Copa <ncopa@alpinelinux.org> fixed
zlib 3.20-main 1.3.1-r1 Natanael Copa <ncopa@alpinelinux.org> fixed