CVE-2023-51258

Name
CVE-2023-51258
Description
A memory leak issue discovered in YASM v.1.3.0 allows a local attacker to cause a denial of service via the new_Token function in the modules/preprocs/nasm/nasm-pp:1512.
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
cve@mitre.org https://github.com/hanxuer/crashes/blob/main/yasm/04/readme.md

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:tortall:yasm:1.3.0:*:*:*:*:*:*:* yasm == None == 1.3.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
yasm edge-community 1.3.0-r4 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
yasm 3.19-community 1.3.0-r4 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
yasm 3.18-main 1.3.0-r4 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
yasm 3.17-main 1.3.0-r3 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
yasm 3.16-main 1.3.0-r2 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable