CVE-2023-5088

Name
CVE-2023-5088
Description
A bug in QEMU could cause a guest I/O operation otherwise addressed to an arbitrary disk offset to be targeted to offset 0 instead (potentially overwriting the VM's boot code). This could be used, for example, by L2 guests with a virtual disk (vdiskL2) stored on a virtual disk of an L1 (vdiskL1) hypervisor to read and/or write data to LBA 0 of vdiskL1, potentially gaining control of L1 at its next reboot.
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://bugzilla.redhat.com/show_bug.cgi?id=2247283
MISC https://access.redhat.com/security/cve/CVE-2023-5088
MISC https://lore.kernel.org/all/20230921160712.99521-1-simon.rowe@nutanix.com/T/
secalert@redhat.com https://security.netapp.com/advisory/ntap-20231208-0005/
secalert@redhat.com https://lists.debian.org/debian-lts-announce/2024/03/msg00012.html

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:qemu:qemu:-:*:*:*:*:*:*:* qemu == None == -
cpe:2.3:a:qemu:qemu:*:*:*:*:*:*:*:* qemu >= None < 8.2.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
qemu 3.19-community 8.1.5-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable