CVE-2023-50186

Name
CVE-2023-50186
Description
GStreamer AV1 Video Parsing Stack-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GStreamer. Interaction with this library is required to exploit this vulnerability but attack vectors may vary depending on the implementation. The specific flaw exists within the parsing of metadata within AV1 encoded video files. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-22300.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
vendor-advisory https://gstreamer.freedesktop.org/security/sa-2023-0011.html
x_research-advisory https://www.zerodayinitiative.com/advisories/ZDI-24-368/

Match rules

CPE URI Source package Min version Max version
gstreamer == bd4a9fde89e2549887e8a77d22ab027bed70d743 == bd4a9fde89e2549887e8a77d22ab027bed70d743
cpe:2.3:a:gstreamer_project:gstreamer:*:*:*:*:*:*:*:* gstreamer >= 0 < 1.22.8

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
gstreamer 3.17-main 1.20.6-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
gstreamer 3.16-main 1.20.3-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable