CVE-2023-49786

Name
CVE-2023-49786
Description
Asterisk is an open source private branch exchange and telephony toolkit. In Asterisk prior to versions 18.20.1, 20.5.1, and 21.0.1; as well as certified-asterisk prior to 18.9-cert6; Asterisk is susceptible to a DoS due to a race condition in the hello handshake phase of the DTLS protocol when handling DTLS-SRTP for media setup. This attack can be done continuously, thus denying new DTLS-SRTP encrypted calls during the attack. Abuse of this vulnerability may lead to a massive Denial of Service on vulnerable Asterisk servers for calls that rely on DTLS-SRTP. Commit d7d7764cb07c8a1872804321302ef93bf62cba05 contains a fix, which is part of versions 18.20.1, 20.5.1, 21.0.1, amd 18.9-cert6.
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
security-advisories@github.com https://github.com/EnableSecurity/advisories/tree/master/ES2023-01-asterisk-dtls-hello-race
security-advisories@github.com https://github.com/asterisk/asterisk/commit/d7d7764cb07c8a1872804321302ef93bf62cba05
security-advisories@github.com https://github.com/asterisk/asterisk/security/advisories/GHSA-hxj9-xwr8-w8pq
security-advisories@github.com http://www.openwall.com/lists/oss-security/2023/12/15/7
security-advisories@github.com http://packetstormsecurity.com/files/176251/Asterisk-20.1.0-Denial-Of-Service.html
security-advisories@github.com http://seclists.org/fulldisclosure/2023/Dec/24
security-advisories@github.com https://lists.debian.org/debian-lts-announce/2023/12/msg00019.html

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:digium:asterisk:*:*:*:*:*:*:*:* asterisk >= None < 18.20.1
cpe:2.3:a:digium:asterisk:*:*:*:*:*:*:*:* asterisk >= 19.0.0 < 20.5.1
cpe:2.3:a:digium:asterisk:21.0.0:*:*:*:*:*:*:* asterisk == None == 21.0.0
cpe:2.3:a:sangoma:certified_asterisk:13.13.0:*:*:*:*:*:*:* certified_asterisk == None == 13.13.0
cpe:2.3:a:sangoma:certified_asterisk:16.8.0:-:*:*:*:*:*:* certified_asterisk == None == 16.8.0
cpe:2.3:a:sangoma:certified_asterisk:18.9:cert1:*:*:*:*:*:* certified_asterisk == None == 18.9

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
asterisk 3.18-main 18.20.2-r0 Timo Teras <timo.teras@iki.fi> fixed
asterisk 3.17-main 18.20.2-r0 Timo Teras <timo.teras@iki.fi> fixed
asterisk 3.16-main 18.20.2-r0 Timo Teras <timo.teras@iki.fi> fixed