CVE-2023-49652

Name
CVE-2023-49652
Description
Incorrect permission checks in Jenkins Google Compute Engine Plugin 4.550.vb_327fca_3db_11 and earlier allow attackers with global Item/Configure permission (while lacking Item/Configure permission on any particular job) to enumerate system-scoped credentials IDs of credentials stored in Jenkins and to connect to Google Cloud Platform using attacker-specified credentials IDs obtained through another method, to obtain information about existing projects. This fix has been backported to 4.3.17.1.
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
https://www.jenkins.io/security/advisory/2023-11-29/#SECURITY-2835
http://www.openwall.com/lists/oss-security/2023/11/29/1

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:google_compute_engine:*:*:*:*:*:jenkins:*:* jenkins >= None < 4.3.17.1

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins 3.18-community 2.387.3-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.19-community 2.414.3-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins edge-community 2.426.3-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable