Vim is an open source command line text editor. When parsing relative ex addresses one may unintentionally cause an overflow. Ironically this happens in the existing overflow check, because the line number becomes negative and LONG_MAX - lnum will cause the overflow. Impact is low, user interaction is required and a crash may not even happen in all situations. This issue has been addressed in commit `060623e` which has been included in release version 9.0.2110. Users are advised to upgrade. There are no known workarounds for this vulnerability.
NVD Severity
Other trackers
Mailing lists
GitHub (code, issues), Aports (code, issues)


Type URI
Mailing List

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:* vim >= None < 9.0.2110

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
vim 3.18-main 9.0.2073-r0 Natanael Copa <> possibly vulnerable
vim 3.17-main 9.0.0999-r0 Natanael Copa <> possibly vulnerable
vim 3.15-main 8.2.4836-r1 Natanael Copa <> possibly vulnerable
vim 3.16-main 8.2.5000-r1 Natanael Copa <> possibly vulnerable