CVE-2023-47994

Name
CVE-2023-47994
Description
An integer overflow vulnerability in LoadPixelDataRLE4 function in PluginBMP.cpp in Freeimage 3.18.0 allows attackers to obtain sensitive information, cause a denial of service and/or run arbitrary code.
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
cve@mitre.org https://github.com/thelastede/FreeImage-cve-poc/tree/master/CVE-2023-47994

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:freeimage_project:freeimage:3.18.0:*:*:*:*:*:*:* freeimage == None == 3.18.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
freeimage edge-community 3.18.0-r4 Taner Tas <taner76@gmail.com> possibly vulnerable
freeimage 3.19-community 3.18.0-r4 Taner Tas <taner76@gmail.com> possibly vulnerable