CVE-2023-46651

Name
CVE-2023-46651
Description
Jenkins Warnings Plugin 10.5.0 and earlier does not set the appropriate context for credentials lookup, allowing attackers with Item/Configure permission to access and capture credentials they are not entitled to. This fix has been backported to 10.4.1.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC http://www.openwall.com/lists/oss-security/2023/10/25/2
MISC https://www.jenkins.io/security/advisory/2023-10-25/#SECURITY-3265

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:warnings:*:*:*:*:*:jenkins:*:* jenkins >= None <= 10.5.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins 3.18-community 2.387.3-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins edge-community 2.440.2-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.19-community 2.440.3-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable