CVE-2023-4584

Name
CVE-2023-4584
Description
Memory safety bugs present in Firefox 116, Firefox ESR 102.14, Firefox ESR 115.1, Thunderbird 102.14, and Thunderbird 115.1. Some of these bugs showed evidence of memory corruption and we presume that with enough effort some of these could have been exploited to run arbitrary code. This vulnerability affects Firefox < 117, Firefox ESR < 102.15, Firefox ESR < 115.2, Thunderbird < 102.15, and Thunderbird < 115.2.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://www.mozilla.org/security/advisories/mfsa2023-34/
MISC https://www.mozilla.org/security/advisories/mfsa2023-36/
MISC https://www.mozilla.org/security/advisories/mfsa2023-35/
MISC https://bugzilla.mozilla.org/buglist.cgi?bug_id=1843968%2C1845205%2C1846080%2C1846526%2C1847529
MISC https://www.mozilla.org/security/advisories/mfsa2023-38/
Vendor Advisory https://www.mozilla.org/security/advisories/mfsa2023-37/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:mozilla:thunderbird:*:*:*:*:*:*:*:* thunderbird >= None < 115.2
cpe:2.3:a:mozilla:firefox_esr:*:*:*:*:*:*:*:* firefox_esr >= 115.0 < 115.2
cpe:2.3:a:mozilla:firefox_esr:*:*:*:*:*:*:*:* firefox_esr >= None < 102.15
cpe:2.3:a:mozilla:firefox:*:*:*:*:*:*:*:* firefox >= None < 117.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status