CVE-2023-4578

Name
CVE-2023-4578
Description
When calling `JS::CheckRegExpSyntax` a Syntax Error could have been set which would end in calling `convertToRuntimeErrorAndClear`. A path in the function could attempt to allocate memory when none is available which would have caused a newly created Out of Memory exception to be mishandled as a Syntax Error. This vulnerability affects Firefox < 117, Firefox ESR < 115.2, and Thunderbird < 115.2.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://www.mozilla.org/security/advisories/mfsa2023-34/
MISC https://bugzilla.mozilla.org/show_bug.cgi?id=1839007
MISC https://www.mozilla.org/security/advisories/mfsa2023-36/
MISC https://www.mozilla.org/security/advisories/mfsa2023-38/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:mozilla:thunderbird:*:*:*:*:*:*:*:* thunderbird >= None < 115.2
cpe:2.3:a:mozilla:firefox:*:*:*:*:*:*:*:* firefox >= None < 117.0
cpe:2.3:a:mozilla:firefox_esr:*:*:*:*:*:*:*:* firefox_esr >= None < 115.2

Vulnerable and fixed packages

Source package Branch Version Maintainer Status