CVE-2023-4303

Name
CVE-2023-4303
Description
Jenkins Fortify Plugin 22.1.38 and earlier does not escape the error message for a form validation method, resulting in an HTML injection vulnerability.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://www.jenkins.io/security/advisory/2023-08-16/#SECURITY-3140

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:fortify:*:*:*:*:*:jenkins:*:* jenkins >= None < 22.2.39

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins 3.18-community 2.387.3-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.19-community 2.440.3-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.20-community 2.440.2-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins edge-community 2.452.2-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable