CVE-2023-4256

Name
CVE-2023-4256
Description
Within tcpreplay's tcprewrite, a double free vulnerability has been identified in the tcpedit_dlt_cleanup() function within plugins/dlt_plugins.c. This vulnerability can be exploited by supplying a specifically crafted file to the tcprewrite binary. This flaw enables a local attacker to initiate a Denial of Service (DoS) attack.
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
secalert@redhat.com https://bugzilla.redhat.com/show_bug.cgi?id=2255212
secalert@redhat.com https://github.com/appneta/tcpreplay/issues/813
secalert@redhat.com https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/V3GYCHPVJ2VFN3D7FI4IRMDVMILLWBRF/
secalert@redhat.com https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/EHUILQV2YJI5TXXXJA5FQ2HJQGFT7NTN/
secalert@redhat.com https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/TMW5CIODKRHUUH7NTAYIRWGSJ56DTGXM/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:broadcom:tcpreplay:4.4.3:*:*:*:*:*:*:* tcpreplay == None == 4.4.3
cpe:2.3:a:broadcom:tcpreplay:4.4.4:*:*:*:*:*:*:* tcpreplay == None == 4.4.4

Vulnerable and fixed packages

Source package Branch Version Maintainer Status