CVE-2023-4091

Name
CVE-2023-4091
Description
A vulnerability was discovered in Samba, where the flaw allows SMB clients to truncate files, even with read-only permissions when the Samba VFS module "acl_xattr" is configured with "acl_xattr:ignore system acls = yes". The SMB protocol allows opening files when the client requests read-only access but then implicitly truncates the opened file to 0 bytes if the client specifies a separate OVERWRITE create disposition request. The issue arises in configurations that bypass kernel file system permissions checks, relying solely on Samba's permissions.
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://www.samba.org/samba/security/CVE-2023-4091.html
MISC https://bugzilla.samba.org/show_bug.cgi?id=15439
MISC https://access.redhat.com/errata/RHSA-2023:6209
MISC https://bugzilla.redhat.com/show_bug.cgi?id=2241882
MISC https://access.redhat.com/security/cve/CVE-2023-4091
MISC https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/ZUMVALLFFDFC53JZMUWA6HPD7HUGAP5I/
https://access.redhat.com/errata/RHSA-2023:6744
https://access.redhat.com/errata/RHSA-2023:7371
https://access.redhat.com/errata/RHSA-2023:7408
https://access.redhat.com/errata/RHSA-2023:7464
https://access.redhat.com/errata/RHSA-2023:7467
https://security.netapp.com/advisory/ntap-20231124-0002/
secalert@redhat.com https://lists.debian.org/debian-lts-announce/2024/04/msg00015.html

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:* samba >= 4.19.0 < 4.19.1
cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:* samba >= 4.18.0 < 4.18.8
cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:* samba >= None < 4.17.12

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
samba 3.17-main 4.16.11-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
samba 3.16-main 4.15.13-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
samba 3.15-main 4.15.13-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable