CVE-2023-40345

Name
CVE-2023-40345
Description
Jenkins Delphix Plugin 3.0.2 and earlier does not set the appropriate context for credentials lookup, allowing attackers with Overall/Read permission to access and capture credentials they are not entitled to.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://www.jenkins.io/security/advisory/2023-08-16/#SECURITY-3214%20(2)
MISC http://www.openwall.com/lists/oss-security/2023/08/16/3
MISC https://support.delphix.com/Support_Policies_and_Technical_Bulletins/Technical_Bulletins/TB111_Delphix_Plugin_for_Jenkins_Vulnerable_to_Credential_Enumeration_and_Capture

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:delphix:*:*:*:*:*:jenkins:*:* jenkins >= None <= 3.0.2

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins 3.18-community 2.387.3-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.19-community 2.414.3-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins edge-community 2.440.2-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable