CVE-2023-38703

Name
CVE-2023-38703
Description
PJSIP is a free and open source multimedia communication library written in C with high level API in C, C++, Java, C#, and Python languages. SRTP is a higher level media transport which is stacked upon a lower level media transport such as UDP and ICE. Currently a higher level transport is not synchronized with its lower level transport that may introduce use-after-free issue. This vulnerability affects applications that have SRTP capability (`PJMEDIA_HAS_SRTP` is set) and use underlying media transport other than UDP. This vulnerability’s impact may range from unexpected application termination to control flow hijack/memory corruption. The patch is available as a commit in the master branch.
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://github.com/pjsip/pjproject/commit/6dc9b8c181aff39845f02b4626e0812820d4ef0d
MISC https://github.com/pjsip/pjproject/security/advisories/GHSA-f76w-fh7c-pc66
security-advisories@github.com https://lists.debian.org/debian-lts-announce/2023/12/msg00019.html

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:teluu:pjsip:*:*:*:*:*:*:*:* pjsip >= None <= 2.13.1

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
pjproject 3.18-main 2.14-r0 Natanael Copa <ncopa@alpinelinux.org> fixed
pjproject 3.19-main 2.14-r0 Natanael Copa <ncopa@alpinelinux.org> fixed