CVE-2023-35866

Name
CVE-2023-35866
Description
In KeePassXC through 2.7.5, a local attacker can make changes to the Database security settings, including master password and second-factor authentication, within an authenticated KeePassXC Database session, without the need to authenticate these changes by entering the password and/or second-factor authentication to confirm changes. NOTE: the vendor's position is "asking the user for their password prior to making any changes to the database settings adds no additional protection against a local attacker."
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://github.com/keepassxreboot/keepassxc/issues/9391
MISC https://github.com/keepassxreboot/keepassxc/issues/9339
MISC https://github.com/keepassxreboot/keepassxc/issues/9339#issuecomment-1598219482
MISC https://keepassxc.org/docs/#faq-yubikey-2fa
MISC https://medium.com/@cybercitizen.tech/keepassxc-vulnerability-cve-2023-35866-dc7d447c4903
https://medium.com/%40cybercitizen.tech/keepassxc-vulnerability-cve-2023-35866-dc7d447c4903

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:keepassxc:keepassxc:*:*:*:*:*:*:*:* keepassxc >= None <= 2.7.5

Vulnerable and fixed packages

Source package Branch Version Maintainer Status