CVE-2023-32643

Name
CVE-2023-32643
Description
A flaw was found in GLib. The GVariant deserialization code is vulnerable to a heap buffer overflow introduced by the fix for CVE-2023-32665. This bug does not affect any released version of GLib, but does affect GLib distributors who followed the guidance of GLib developers to backport the initial fix for CVE-2023-32665.
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://https://discourse.gnome.org/t/multiple-fixes-for-gvariant-normalisation-issues-in-glib/12835
MISC https://gitlab.gnome.org/GNOME/glib/-/issues/2840
secalert@redhat.com https://security.netapp.com/advisory/ntap-20240426-0005/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:gnome:glib:*:*:*:*:*:*:*:* glib >= None < 2.75.1

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
glib 3.17-main 2.74.7-r0 Rasmus Thomsen <oss@cogitri.dev> possibly vulnerable
glib 3.16-main 2.72.4-r0 Rasmus Thomsen <oss@cogitri.dev> possibly vulnerable
glib 3.15-main 2.70.5-r0 Rasmus Thomsen <oss@cogitri.dev> possibly vulnerable