CVE-2023-31974

Name
CVE-2023-31974
Description
yasm v1.3.0 was discovered to contain a use after free via the function error at /nasm/nasm-pp.c.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://github.com/yasm/yasm/issues/208

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:tortall:yasm:1.3.0:*:*:*:*:*:*:* yasm == None == 1.3.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
yasm 3.17-main 1.3.0-r3 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
yasm 3.16-main 1.3.0-r2 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
yasm 3.15-main 1.3.0-r2 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
yasm 3.14-main 1.3.0-r2 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
yasm edge-community 1.3.0-r4 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
yasm 3.18-main 1.3.0-r4 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable