CVE-2023-30581

Name
CVE-2023-30581
Description
The use of __proto__ in process.mainModule.__proto__.require() can bypass the policy mechanism and require modules outside of the policy.json definition. This vulnerability affects all users using the experimental policy mechanism in all active release lines: v16, v18 and, v20. Please note that at the time this CVE was issued, the policy is an experimental feature of Node.js
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
https://nodejs.org/en/blog/vulnerability/june-2023-security-releases

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:* nodejs >= 16.0.0 <= 20.6.1
cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:* nodejs >= 16.0.0 < 16.20.1
cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:* nodejs >= 18.0.0 < 18.16.1
cpe:2.3:a:nodejs:node.js:*:*:*:*:-:*:*:* nodejs >= 20.0.0 < 20.3.1

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
nodejs 3.16-main 16.20.2-r0 Jakub Jirutka <jakub@jirutka.cz> possibly vulnerable
nodejs 3.15-main 16.20.2-r0 Jakub Jirutka <jakub@jirutka.cz> possibly vulnerable
nodejs 3.17-main 18.19.1-r0 Jakub Jirutka <jakub@jirutka.cz> possibly vulnerable
nodejs 3.18-main 18.19.1-r0 Jakub Jirutka <jakub@jirutka.cz> possibly vulnerable