CVE-2023-28672

Name
CVE-2023-28672
Description
Jenkins OctoPerf Load Testing Plugin Plugin 4.5.1 and earlier does not perform a permission check in a connection test HTTP endpoint, allowing attackers with Overall/Read permission to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://www.jenkins.io/security/advisory/2023-03-21/#SECURITY-3067%20(2)

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:octoperf_load_testing:*:*:*:*:*:jenkins:*:* jenkins >= None <= 4.5.1

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins 3.17-community 2.361.2-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.18-community 2.387.3-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins edge-community 2.414.3-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable