CVE-2023-28669

Name
CVE-2023-28669
Description
Jenkins JaCoCo Plugin 3.3.2 and earlier does not escape class and method names shown on the UI, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control input files for the 'Record JaCoCo coverage report' post-build action.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://www.jenkins.io/security/advisory/2023-03-21/#SECURITY-3061

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:jacoco:*:*:*:*:*:jenkins:*:* jenkins >= None <= 3.3.2

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins 3.17-community 2.361.2-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.18-community 2.387.3-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.19-community 2.414.3-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins edge-community 2.440.2-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable