homeassistant is an open source home automation tool. A remotely exploitable vulnerability bypassing authentication for accessing the Supervisor API through Home Assistant has been discovered. This impacts all Home Assistant installation types that use the Supervisor 2023.01.1 or older. Installation types, like Home Assistant Container (for example Docker), or Home Assistant Core manually in a Python environment, are not affected. The issue has been mitigated and closed in Supervisor version 2023.03.1, which has been rolled out to all affected installations via the auto-update feature of the Supervisor. This rollout has been completed at the time of publication of this advisory. Home Assistant Core 2023.3.0 included mitigation for this vulnerability. Upgrading to at least that version is thus advised. In case one is not able to upgrade the Home Assistant Supervisor or the Home Assistant Core application at this time, it is advised to not expose your Home Assistant instance to the internet.
NVD Severity
Other trackers
Mailing lists
GitHub (code, issues), Aports (code, issues)


Type URI

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:home-assistant:supervisor:*:*:*:*:*:*:*:* supervisor >= None < 2023.03.1
cpe:2.3:a:home-assistant:home-assistant:*:*:*:*:*:*:*:* home-assistant >= None < 2023.3.0
cpe:2.3:a:home-assistant:supervisor:*:*:*:*:*:*:*:* homeassistant-supervisor >= None < 2023.03.1

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
supervisor 3.17-main 4.2.4-r0 None possibly vulnerable
supervisor 3.16-main 4.2.4-r0 None possibly vulnerable
supervisor 3.15-main 4.2.2-r2 None possibly vulnerable
supervisor 3.14-main 4.2.2-r2 None possibly vulnerable
supervisor 3.18-main 4.2.5-r2 None possibly vulnerable
supervisor edge-main 4.2.5-r4 Natanael Copa <> possibly vulnerable
supervisor 3.19-main 4.2.5-r4 Natanael Copa <> possibly vulnerable