CVE-2023-26930

Name
CVE-2023-26930
Description
Buffer Overflow vulnerability found in XPDF v.4.04 allows an attacker to cause a Denial of Service via the PDFDoc malloc in the pdftotext.cc function.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://github.com/huanglei3/xpdf_aborted
MISC https://gist.github.com/huanglei3/10e2a9bd07a109995b20ade306612a34

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:xpdfreader:xpdf:4.04:*:*:*:*:*:*:* xpdf == None == 4.04

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
xpdf edge-community 4.04-r0 Dominika Liberda <ja@sdomi.pl> possibly vulnerable
xpdf 3.17-community 4.04-r0 Dominika Liberda <ja@sdomi.pl> possibly vulnerable
xpdf 3.18-community 4.04-r0 Dominika Liberda <ja@sdomi.pl> possibly vulnerable