CVE-2023-23847

Name
CVE-2023-23847
Description
A cross-site request forgery (CSRF) vulnerability in Synopsys Jenkins Coverity Plugin 3.0.2 and earlier allows attackers to connect to an attacker-specified HTTP server using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.
NVD Severity
low
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://www.jenkins.io/security/advisory/2023-02-15/#SECURITY-2793%20(2)
CONFIRM https://community.synopsys.com/s/article/SIG-Product-Security-Advisory-Multiple-CVEs-affecting-Coverity-Jenkins-Plugin
https://www.jenkins.io/security/advisory/2023-02-15/#SECURITY-2793%20%282%29

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:synopsys_coverity:*:*:*:*:*:jenkins:*:* jenkins >= None < 3.0.3

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins 3.17-community 2.361.2-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.18-community 2.387.3-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.19-community 2.440.3-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.20-community 2.440.2-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins edge-community 2.452.2-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable