CVE-2023-22036

Name
CVE-2023-22036
Description
Vulnerability in the Oracle Java SE, Oracle GraalVM Enterprise Edition, Oracle GraalVM for JDK product of Oracle Java SE (component: Utility). Supported versions that are affected are Oracle Java SE: 11.0.19, 17.0.7, 20.0.1; Oracle GraalVM Enterprise Edition: 20.3.10, 21.3.6, 22.3.2; Oracle GraalVM for JDK: 17.0.7 and 20.0.1. Difficult to exploit vulnerability allows unauthenticated attacker with network access via multiple protocols to compromise Oracle Java SE, Oracle GraalVM Enterprise Edition, Oracle GraalVM for JDK. Successful attacks of this vulnerability can result in unauthorized ability to cause a partial denial of service (partial DOS) of Oracle Java SE, Oracle GraalVM Enterprise Edition, Oracle GraalVM for JDK. Note: This vulnerability can be exploited by using APIs in the specified Component, e.g., through a web service which supplies data to the APIs. This vulnerability also applies to Java deployments, typically in clients running sandboxed Java Web Start applications or sandboxed Java applets, that load and run untrusted code (e.g., code that comes from the internet) and rely on the Java sandbox for security. CVSS 3.1 Base Score 3.7 (Availability impacts). CVSS Vector: (CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L).
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://www.oracle.com/security-alerts/cpujul2023.html
MISC https://security.netapp.com/advisory/ntap-20230725-0006/
MISC https://www.debian.org/security/2023/dsa-5458
MISC https://www.debian.org/security/2023/dsa-5478
MISC https://lists.debian.org/debian-lts-announce/2023/09/msg00018.html

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:oracle:jre:17.0.7:*:*:*:*:*:*:* jre == None == 17.0.7
cpe:2.3:a:oracle:jre:11.0.19:*:*:*:*:*:*:* jre == None == 11.0.19
cpe:2.3:a:oracle:jdk:17.0.7:*:*:*:*:*:*:* jdk == None == 17.0.7
cpe:2.3:a:oracle:jdk:11.0.19:*:*:*:*:*:*:* jdk == None == 11.0.19
cpe:2.3:a:oracle:graalvm_for_jdk:20.0.1:*:*:*:*:*:*:* graalvm_for_jdk == None == 20.0.1
cpe:2.3:a:oracle:graalvm:21.3.6:*:*:*:enterprise:*:*:* graalvm == None == 21.3.6
cpe:2.3:a:oracle:graalvm:22.3.2:*:*:*:enterprise:*:*:* graalvm == None == 22.3.2
cpe:2.3:a:oracle:graalvm:20.3.10:*:*:*:enterprise:*:*:* graalvm == None == 20.3.10
cpe:2.3:a:oracle:jdk:20.0.1:*:*:*:*:*:*:* jdk == None == 20.0.1
cpe:2.3:a:oracle:jre:20.0.1:*:*:*:*:*:*:* jre == None == 20.0.1
cpe:2.3:a:oracle:graalvm_for_jdk:17.0.7:*:*:*:*:*:*:* graalvm_for_jdk == None == 17.0.7

Vulnerable and fixed packages

Source package Branch Version Maintainer Status