CVE-2023-2157

Name
CVE-2023-2157
Description
A heap-based buffer overflow vulnerability was found in the ImageMagick package that can lead to the application crashing.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://bugzilla.redhat.com/show_bug.cgi?id=2208537
https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/45DUUXYMAEEAW55GSLAXN25VPKCRAIDA/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:imagemagick:imagemagick:*:*:*:*:*:*:*:* imagemagick >= None < 7.1.1-9

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
imagemagick 3.18-community 7.1.1.13-r1 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
imagemagick 3.19-community 7.1.1.26-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
imagemagick edge-community 7.1.1.29-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable