CVE-2023-1410

Name
CVE-2023-1410
Description
Grafana is an open-source platform for monitoring and observability.  Grafana had a stored XSS vulnerability in the Graphite FunctionDescription tooltip. The stored XSS vulnerability was possible due the value of the Function Description was not properly sanitized. An attacker needs to have control over the Graphite data source in order to manipulate a function description and a Grafana admin needs to configure the data source, later a Grafana user needs to select a tampered function and hover over the description.  Users may upgrade to version 8.5.22, 9.2.15 and 9.3.11 to receive a fix.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://github.com/grafana/bugbounty/security/advisories/GHSA-qrrg-gw7w-vp76
MISC https://grafana.com/security/security-advisories/cve-2023-1410/
MISC https://security.netapp.com/advisory/ntap-20230420-0003/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:grafana:grafana:*:*:*:*:*:*:*:* grafana > 9.3.0 < 9.3.11
cpe:2.3:a:grafana:grafana:*:*:*:*:*:*:*:* grafana >= 9.2.0 < 9.2.15
cpe:2.3:a:grafana:grafana:*:*:*:*:*:*:*:* grafana >= 8.0.0 < 8.5.22

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
grafana 3.17-community 9.2.5-r4 Konstantin Kulikov <k.kulikov2@gmail.com> possibly vulnerable