CVE-2022-46684

Name
CVE-2022-46684
Description
Jenkins Checkmarx Plugin 2022.3.3 and earlier does not escape values returned from the Checkmarx service API before inserting them into HTML reports, resulting in a stored cross-site scripting (XSS) vulnerability.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://www.jenkins.io/security/advisory/2022-12-07/#SECURITY-2869

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:checkmarx:*:*:*:*:*:jenkins:*:* jenkins >= None < 2022.4.3

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins edge-community 2.361.2-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.17-community 2.361.2-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable