CVE-2022-46149

Name
CVE-2022-46149
Description
Cap'n Proto is a data interchange format and remote procedure call (RPC) system. Cap'n Proro prior to versions 0.7.1, 0.8.1, 0.9.2, and 0.10.3, as well as versions of Cap'n Proto's Rust implementation prior to 0.13.7, 0.14.11, and 0.15.2 are vulnerable to out-of-bounds read due to logic error handling list-of-list. This issue may lead someone to remotely segfault a peer by sending it a malicious message, if the victim performs certain actions on a list-of-pointer type. Exfiltration of memory is possible if the victim performs additional certain actions on a list-of-pointer type. To be vulnerable, an application must perform a specific sequence of actions, described in the GitHub Security Advisory. The bug is present in inlined code, therefore the fix will require rebuilding dependent applications. Cap'n Proto has C++ fixes available in versions 0.7.1, 0.8.1, 0.9.2, and 0.10.3. The `capnp` Rust crate has fixes available in versions 0.13.7, 0.14.11, and 0.15.2.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://github.com/capnproto/capnproto/commit/25d34c67863fd960af34fc4f82a7ca3362ee74b9
CONFIRM https://github.com/capnproto/capnproto/security/advisories/GHSA-qqff-4vw4-f6hx
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WKXM4JAFXLTXU5IQB3OUBQVCIICZWGYX/
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/ZOCQQOPMVQOFUWBWAGVGN76OYAV3WXY4/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:capnproto:capnproto:*:*:*:*:*:*:*:* capnproto >= 0.9.0 < 0.9.2
cpe:2.3:a:capnproto:capnproto:*:*:*:*:*:*:*:* capnproto >= None < 0.7.1
cpe:2.3:a:capnproto:capnproto:0.8.0:*:*:*:*:*:*:* capnproto == None == 0.8.0
cpe:2.3:a:capnproto:capnproto:*:*:*:*:*:*:*:* capnproto >= 0.10.0 < 0.10.3

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
capnproto 3.17-community 0.10.2-r1 Luca Weiss <luca@z3ntu.xyz> possibly vulnerable