CVE-2022-45141

Name
CVE-2022-45141
Description
Since the Windows Kerberos RC4-HMAC Elevation of Privilege Vulnerability was disclosed by Microsoft on Nov 8 2022 and per RFC8429 it is assumed that rc4-hmac is weak, Vulnerable Samba Active Directory DCs will issue rc4-hmac encrypted tickets despite the target server supporting better encryption (eg aes256-cts-hmac-sha1-96).
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://www.samba.org/samba/security/CVE-2022-45141.html
GENTOO https://security.gentoo.org/glsa/202309-06

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:* samba >= 4.16.0 < 4.16.8
cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:* samba >= None < 4.15.13

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
samba 3.15-main 4.15.13-r0 Natanael Copa <ncopa@alpinelinux.org> fixed
samba 3.14-main 4.14.14-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
samba 3.16-main 4.15.13-r0 Natanael Copa <ncopa@alpinelinux.org> fixed