CVE-2022-44638

Name
CVE-2022-44638
Description
In libpixman in Pixman before 0.42.2, there is an out-of-bounds write (aka heap-based buffer overflow) in rasterize_edges_8 due to an integer overflow in pixman_sample_floor_y.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://gitlab.freedesktop.org/pixman/pixman/-/issues/63
MLIST http://www.openwall.com/lists/oss-security/2022/11/05/1
MLIST https://lists.debian.org/debian-lts-announce/2022/11/msg00008.html
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/BY4OPSIB33ETNUXZY2UPZ4NGQ3OKDY4D/
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/IUJ2BULJTZ2BMSKQHB6US674P55UCWWS/
DEBIAN https://www.debian.org/security/2022/dsa-5276
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/AJ5VY2VYXE4WTRGQ6LMGLF6FV3SY37YE/
Exploit http://packetstormsecurity.com/files/170121/pixman-pixman_sample_floor_y-Integer-Overflow.html
https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BY4OPSIB33ETNUXZY2UPZ4NGQ3OKDY4D/
https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/AJ5VY2VYXE4WTRGQ6LMGLF6FV3SY37YE/
https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IUJ2BULJTZ2BMSKQHB6US674P55UCWWS/

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:pixman:pixman:*:*:*:*:*:*:*:* pixman >= None < 0.42.2

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
pixman 3.16-main 0.40.0-r4 Natanael Copa <ncopa@alpinelinux.org> fixed
pixman 3.15-main 0.40.0-r4 Natanael Copa <ncopa@alpinelinux.org> fixed
pixman 3.14-main 0.40.0-r3 Natanael Copa <ncopa@alpinelinux.org> fixed
pixman 3.13-main 0.40.0-r3 Natanael Copa <ncopa@alpinelinux.org> fixed