CVE-2022-43995

Name
CVE-2022-43995
Description
Sudo 1.8.0 through 1.9.12, with the crypt() password backend, contains a plugins/sudoers/auth/passwd.c array-out-of-bounds error that can result in a heap-based buffer over-read. This can be triggered by arbitrary local users with access to Sudo by entering a password of seven characters or fewer. The impact could vary depending on the system libraries, compiler, and processor architecture.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://github.com/sudo-project/sudo/commit/bd209b9f16fcd1270c13db27ae3329c677d48050
MISC https://www.sudo.ws/security/advisories/
MISC https://news.ycombinator.com/item?id=33465707
MISC https://bugzilla.redhat.com/show_bug.cgi?id=2139911
GENTOO https://security.gentoo.org/glsa/202211-08

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:sudo_project:sudo:*:*:*:*:*:*:*:* sudo >= 1.8.0 <= 1.9.12

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
sudo 3.15-main 1.9.12-r1 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
sudo 3.16-community 1.9.12-r1 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
sudo 3.14-main 1.9.12-r1 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
sudo 3.13-main 1.9.12-r1 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable