CVE-2022-43406

Name
CVE-2022-43406
Description
A sandbox bypass vulnerability in Jenkins Pipeline: Deprecated Groovy Libraries Plugin 583.vf3b_454e43966 and earlier allows attackers with permission to define untrusted Pipeline libraries and to define and run sandboxed scripts, including Pipelines, to bypass the sandbox protection and execute arbitrary code in the context of the Jenkins controller JVM.
NVD Severity
high
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://www.jenkins.io/security/advisory/2022-10-19/#SECURITY-2824%20(2)
MLIST http://www.openwall.com/lists/oss-security/2022/10/19/3

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:jenkins:groovy_libraries:*:*:*:*:*:jenkins:*:* jenkins >= None <= 583.vf3b_454e43966

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
jenkins 3.16-community 2.346.2-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins edge-community 2.361.2-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable
jenkins 3.17-community 2.361.2-r0 Francesco Colista <fcolista@alpinelinux.org> possibly vulnerable