CVE-2022-42705

Name
CVE-2022-42705
Description
A use-after-free in res_pjsip_pubsub.c in Sangoma Asterisk 16.28, 18.14, 19.6, and certified/18.9-cert2 may allow a remote authenticated attacker to crash Asterisk (denial of service) by performing activity on a subscription via a reliable transport at the same time that Asterisk is also performing activity on that subscription.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://downloads.asterisk.org/pub/security/AST-2022-008.html

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:sangoma:certified_asterisk:18.9:cert2:*:*:*:*:*:* certified_asterisk == None == 18.9
cpe:2.3:a:sangoma:asterisk:*:*:*:*:*:*:*:* asterisk >= 19.6.0 < 19.7.1
cpe:2.3:a:sangoma:asterisk:*:*:*:*:*:*:*:* asterisk >= 18.14.0 < 18.15.1
cpe:2.3:a:sangoma:asterisk:*:*:*:*:*:*:*:* asterisk >= 16.0.0 < 16.29.1
cpe:2.3:a:sangoma:asterisk:20.0.0:*:*:*:*:*:*:* asterisk == None == 20.0.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
asterisk 3.17-main 18.15.0-r0 Timo Teras <timo.teras@iki.fi> possibly vulnerable
asterisk edge-main 18.15.0-r2 Timo Teras <timo.teras@iki.fi> possibly vulnerable