CVE-2022-42331

Name
CVE-2022-42331
Description
x86: speculative vulnerability in 32bit SYSCALL path Due to an oversight in the very original Spectre/Meltdown security work (XSA-254), one entrypath performs its speculation-safety actions too late. In some configurations, there is an unprotected RET instruction which can be attacked with a variety of speculative attacks.
NVD Severity
unknown
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
MISC https://xenbits.xenproject.org/xsa/advisory-429.txt
CONFIRM http://xenbits.xen.org/xsa/advisory-429.html
MLIST http://www.openwall.com/lists/oss-security/2023/03/21/3
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/APBMS2Q6746AXAFAITNJMGBNFGNMVLWR/
FEDORA https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/5L6PM4RE7MUE6OWA32ZVOXCP235RM2TM/
DEBIAN https://www.debian.org/security/2023/dsa-5378
MISC https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/5L6PM4RE7MUE6OWA32ZVOXCP235RM2TM/
MISC https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/APBMS2Q6746AXAFAITNJMGBNFGNMVLWR/
security@xen.org https://security.gentoo.org/glsa/202402-07

Match rules

CPE URI Source package Min version Max version
cpe:2.3:o:xen:xen:*:*:*:*:*:*:x86:* xen >= 4.5.0 <= 4.17.0

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
xen 3.14-main 4.15.4-r0 Natanael Copa <ncopa@alpinelinux.org> possibly vulnerable
xen 3.15-main 4.15.5-r4 Natanael Copa <ncopa@alpinelinux.org> fixed
xen 3.17-main 4.16.6-r0 Natanael Copa <ncopa@alpinelinux.org> fixed
xen 3.16-main 4.16.6-r0 Natanael Copa <ncopa@alpinelinux.org> fixed