CVE-2022-41916

Name
CVE-2022-41916
Description
Heimdal is an implementation of ASN.1/DER, PKIX, and Kerberos. Versions prior to 7.7.1 are vulnerable to a denial of service vulnerability in Heimdal's PKI certificate validation library, affecting the KDC (via PKINIT) and kinit (via PKINIT), as well as any third-party applications using Heimdal's libhx509. Users should upgrade to Heimdal 7.7.1 or 7.8. There are no known workarounds for this issue.
NVD Severity
medium
Other trackers
Mailing lists
Exploits
Forges
GitHub (code, issues), Aports (code, issues)

References

Type URI
CONFIRM https://github.com/heimdal/heimdal/security/advisories/GHSA-mgqr-gvh6-23cx
DEBIAN https://www.debian.org/security/2022/dsa-5287

Match rules

CPE URI Source package Min version Max version
cpe:2.3:a:heimdal_project:heimdal:*:*:*:*:*:*:*:* heimdal >= None < 7.7.1

Vulnerable and fixed packages

Source package Branch Version Maintainer Status
heimdal 3.16-main 7.7.0-r7 Leonardo Arena <rnalrd@alpinelinux.org> possibly vulnerable
heimdal 3.15-main 7.7.0-r7 Leonardo Arena <rnalrd@alpinelinux.org> possibly vulnerable
heimdal 3.13-main 7.7.0-r4 Leonardo Arena <rnalrd@alpinelinux.org> possibly vulnerable
heimdal 3.14-main 7.7.1-r0 Leonardo Arena <rnalrd@alpinelinux.org> fixed